Changing Aspnet database

Mar 13, 2011 at 10:41 PM

I downloaded the MyWSAT package on a local machine (Vista x64). Out of the box everything works fine with the default database and admin account.

I have an existing aspnet database on my webhost (godaddy) with users and roles. I used Visual Studio 2010 Express to open a copy of the MyWSAT package. I edited the web.config like this: <add name="VSI" connectionString="Data Source=vsixxx.db.7374430.hostedresource.com;Initial Catalog=vsixxx;User ID=vsiuser;Password=password" providerName="System.Data.SqlClient"/>. I also changed all references to connectionStringName="VSI" in the web.config.

When I run the package I can login with my VSI admin account successfully. But the admin tool and menu does not display. I am stuck on the Login page.  Which states:

LOGIN
Howdy! VSIadmin

You are currently logged in.

Logout

-------------------------

Any thoughts or ideas on how to configure the tool with an existing aspnet database?

 

Mar 13, 2011 at 10:45 PM

By the way I also scripted the stored procs ( sp_admin_xxx, etc.) and the tables (admin_hints, site_themecss, site_themes) in dbMyCMS and applied to the existing database on the webhost.

Mar 14, 2011 at 3:06 AM

I found my answer. I missed a stored proc! 

Feb 22, 2016 at 6:40 PM
Hi sdescon,

I have the similar issue now and only allow me to get on login page then stuck moving to Admin pages. How do you resolve the Stored Proc Part? Do I need to run app_data/* command? Also if I am not using express sql but using existing sql srv how do I move to db part there? Thanks.
Feb 23, 2016 at 1:48 PM
never mind, resolved.